Login | Register
My pages Projects Community openCollabNet

sin
Reply to message

* = Required fields
* Subject
* Body
Attachments
Send reply to
Topic
Author (directly in email)
Please type the letters in the image above.

Original message

Author Anders Hedberg <anders.hedberg@factorycode.com>
Full name Anders Hedberg <anders.hedberg@factorycode.com>
Date 2005-09-17 06:00:21 PDT
Message Might not be a user question, where should I send these kind of mails?

Anyway, I'm doing this and it does not work:
C:\PROGRA~1\Sin​>\mono\bin\mono --debug --trace sin.control.exe start
---
In the file Main.cs, StartIntegrator() checks if we are running mono or not,
I am running Mono on Windows, but the StartIntegratorNET() is still called
which seems to be the problem.

Probably problematic if clause:
private static void StartIntegrator()
        {
            if (Platform.ID == NETPlatformID.NET)
                StartIntegratorNET();
            else
                StartIntegratorMono();
        }

---
Trace list:
in <0x0001a> Sin.Control.MainClas​s:StartIntegratorNET​ ()
in <0x0001e> Sin.Control.MainClas​s:StartIntegrator ()
in <0x00061> Sin.Control.MainClass:Main (System.String[] args)]
. . . . . LEAVE: (wrapper runtime-invoke)
System.Object:runtim​e_invoke_string (o
bject,intptr,intptr,​intptr)[System.Strin​g:01B2CCC0]

Unhandled Exception: System.Exception: Cannot open service named Integrator
Serv
ice.
System error code was 0.
in <0x0016f> Sin.Library.ServiceI​nstaller:IsServiceSt​arted (System.String
svcNam
e)
in <0x0001a> Sin.Control.MainClas​s:StartIntegratorNET​ ()
in <0x0001e> Sin.Control.MainClas​s:StartIntegrator ()
in <0x00061> Sin.Control.MainClass:Main (System.String[] args)

---
Anders dot Hedberg at factorycode dot com
Mobile +46 733 320196
http://www.factorycode.com